Odometer Help?

Discussion in 'Kitsap' started by noob636, Apr 21, 2012.


  1. noob636

    noob636
    Expand Collapse

    217
    0
    186
    Location:
    Silverdale
    So, the bike is all back together and running great. I took for a short test ride and noticed that when i got back, the odometer said that same thing as when i left. i know i rode for about 20 minutes, just kept it short to check for and glitches, and nothing changed on the odometer. Any thoughts?
     
  2. firedad

    firedad
    Expand Collapse

    2,847
    6
    593
    Location:
    The shallow end of the gene pool
    I Ride:
    meh
    It'll help when you resell the bike and has low miles? lol
     
  3. noob636

    noob636
    Expand Collapse

    217
    0
    186
    Location:
    Silverdale
    too bad its stuck at 23005 miles
     
  4. koorbloh

    koorbloh
    Expand Collapse
    Je Fa Fa

    19,782
    3
    1,768
    Location:
    Monroe-mish, WA
    I Ride:
    dirty bikes!
    how's your speedo working?
     
  5. Buz

    Buz
    Expand Collapse

    7,473
    0
    1,116
    Location:
    Bremerton,WA
    Is the VSS (vehicle speed sensor) plugged in and working?
     
  6. Andy Capp

    Andy Capp
    Expand Collapse

    5,283
    5
    768
    Location:
    Marysville, WA
    Forgot the magnet on the counter shaft sprocket?
     
    #6 Andy Capp, Apr 22, 2012
    Last edited: Apr 22, 2012
  7. noob636

    noob636
    Expand Collapse

    217
    0
    186
    Location:
    Silverdale
    the light is on. i will check again

    speedometer is working fine.
     
Loading...
Similar Threads Forum Date
Where is the odometer info stored? Mechanical & Technical May 11, 2014
Question here!? Odometer cable Portland Region Jul 24, 2013
silver/blk 2006 gsxr 750 clean/clear montana title 8k miles on the odometer Motorcycles Jul 23, 2012
Just hit 40K on the odometer Motorcycle Talk Sep 2, 2011
Odometer Status "E" on WA title Motorcycle Talk Aug 27, 2011

Share This Page